$re = '/\.[^«]*«[^»]*»/m';
$str = 'Text1.
Textt « text2 »
Some other text';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;