use strict;
my $str = 'Text1.
Textt « text2 »
Some other text';
my $regex = qr/\.[^«]*«[^»]*»/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";