$re = '/^(?:(?:[[:xdigit:]]{4}\.){2}[[:xdigit:]]{4}|(?:[[:xdigit:]]{2}[:-]){5}[[:xdigit:]]{2}|[[:xdigit:]]{12})$/mi';
$str = '1234567890abcd
12:34:56:78:90:12
12-34-56-78-90-12
1234.5678.9012
123456789012
12:34:56:78:90:12:34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);