import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^LOG:(?:[^,]*,){4}\\K(?!0+,)([^,]*)";
final String string = "LOG:69369,1,30,40,80,06,1\n"
+ "LOG:69369,1,30,40,C0,06,1\n"
+ "POS:69453,69576034,-19244227,1,0\n"
+ "LOG:69405,2,30,40,00,06,2\n"
+ "POS:69333,69576024,-19244235,1,0\n"
+ "LOG:69405,2,30,40,C0,06,2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}