const regex = /^LOG:(?:[^,]*,){4}\K(?!0+,)([^,]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^LOG:(?:[^,]*,){4}\\K(?!0+,)([^,]*)', 'gm')
const str = `LOG:69369,1,30,40,80,06,1
LOG:69369,1,30,40,C0,06,1
POS:69453,69576034,-19244227,1,0
LOG:69405,2,30,40,00,06,2
POS:69333,69576024,-19244235,1,0
LOG:69405,2,30,40,C0,06,2 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}