package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/([^\/]*)\?[^\/]*$`)
var str = `http://www.website.com/page/support/28685875?JK.kj_id=`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}