re = /\/([^\/]*)\?[^\/]*$/
str = 'http://www.website.com/page/support/28685875?JK.kj_id='
# Print the match result
str.match(re) do |match|
puts match.to_s
end