using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1str|2str|3str";
string input = @"123 2str 3str 1str";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}