package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1str|2str|3str`)
var str = `123 2str 3str 1str`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}