#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|[^%])%%\w+%%(?=[^%]|$)"
Local $sString = "%%HELLO_WOLD%%" & @CRLF & _
"%HELLO_WOLD%" & @CRLF & _
"%%HELLO_WOLD" & @CRLF & _
"HELLO_WOLD%%" & @CRLF & _
"Test %%HELLO_WOLD%% test" & @CRLF & _
"Test %%HELLO_WOLD%%" & @CRLF & _
"%%HELLO_WOLD%% test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test %%%HELLO_WOLD%%% test Test %%%HELLO_WOLD%%% test" & @CRLF & _
"Test %%%%%%%%%%%HELLO_WOLD%%%% test" & @CRLF & _
"Test %%%%%%%%%%%%HELLO_WOLD%%%%% test" & @CRLF & _
"%%%HELLO_WOLD%% test" & @CRLF & _
"%HELLO_WOLD% test" & @CRLF & _
"test %%%HELLO_WOLD%% test" & @CRLF & _
"test %%%HELLO_WOLD%% test" & @CRLF & _
"%%%HELLO_WOLD%%" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")