import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[^%])%%\\w+%%(?=[^%]|$)";
final String string = "%%HELLO_WOLD%%\n"
+ "%HELLO_WOLD%\n"
+ "%%HELLO_WOLD\n"
+ "HELLO_WOLD%%\n"
+ "Test %%HELLO_WOLD%% test\n"
+ "Test %%HELLO_WOLD%%\n"
+ "%%HELLO_WOLD%% test\n\n\n\n"
+ "Test %%%HELLO_WOLD%%% test Test %%%HELLO_WOLD%%% test\n"
+ "Test %%%%%%%%%%%HELLO_WOLD%%%% test\n"
+ "Test %%%%%%%%%%%%HELLO_WOLD%%%%% test\n"
+ "%%%HELLO_WOLD%% test\n"
+ "%HELLO_WOLD% test\n"
+ "test %%%HELLO_WOLD%% test\n"
+ "test %%%HELLO_WOLD%% test\n"
+ "%%%HELLO_WOLD%%\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}