re = /(?<=^|[^%])%%\w+%%(?=[^%]|$)/m
str = '%%HELLO_WOLD%%
%HELLO_WOLD%
%%HELLO_WOLD
HELLO_WOLD%%
Test %%HELLO_WOLD%% test
Test %%HELLO_WOLD%%
%%HELLO_WOLD%% test
Test %%%HELLO_WOLD%%% test Test %%%HELLO_WOLD%%% test
Test %%%%%%%%%%%HELLO_WOLD%%%% test
Test %%%%%%%%%%%%HELLO_WOLD%%%%% test
%%%HELLO_WOLD%% test
%HELLO_WOLD% test
test %%%HELLO_WOLD%% test
test %%%HELLO_WOLD%% test
%%%HELLO_WOLD%%
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end