const regex = /\b(\w+\s+\w+)\b.*\b\1\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+\\s+\\w+)\\b.*\\b\\1\\b', 'gm')
const str = `cercival cancer is important cervical diane
cervical cancer is important cervical cancer rate in the states" (cervical cancer)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}