re = /\b(\w+\s+\w+)\b.*\b\1\b/m
str = 'cercival cancer is important cervical diane
cervical cancer is important cervical cancer rate in the states" (cervical cancer)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end