$re = '/\b(\w+\s+\w+)\b.*\b\1\b/m';
$str = 'cercival cancer is important cervical diane
cervical cancer is important cervical cancer rate in the states" (cervical cancer)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);