#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).171(\.\d+){3}(?:.2.1(?:00|6).1.2.0.1|.5.2.20.0.2)"
Local $sString = ".171.11.113.1.5.2.20.0.2" & @CRLF & _
".171.11.119.2.2.100.1.2.0.1" & @CRLF & _
".171.11.119.6.2.100.1.2.0.1" & @CRLF & _
".171.11.70.8.2.16.1.2.0.1" & @CRLF & _
".171.11.118.2.2.100.1.2.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")