import Foundation
let pattern = #".171(\.\d+){3}(?:.2.1(?:00|6).1.2.0.1|.5.2.20.0.2)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.171.11.113.1.5.2.20.0.2
.171.11.119.2.2.100.1.2.0.1
.171.11.119.6.2.100.1.2.0.1
.171.11.70.8.2.16.1.2.0.1
.171.11.118.2.2.100.1.2.0.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)