// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).171(\.\d+){3}(?:.2.1(?:00|6).1.2.0.1|.5.2.20.0.2)").unwrap();
let string = ".171.11.113.1.5.2.20.0.2
.171.11.119.2.2.100.1.2.0.1
.171.11.119.6.2.100.1.2.0.1
.171.11.70.8.2.16.1.2.0.1
.171.11.118.2.2.100.1.2.0.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}