# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)chocolate/\1banana/;t' <<< "I like chocolate but I hate chocolate syrup"