use strict;
my $str = 'I like chocolate but I hate chocolate syrup';
my $regex = qr/(.*)chocolate/p;
my $subst = '\\1banana';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";