$re = '/(.*)chocolate/';
$str = 'I like chocolate but I hate chocolate syrup';
$subst = "\1banana";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;