package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?\d+(-\d+)*$`)
var str = `12345
123-456
+12345
+12345-12345
123--123
123-------3242-324324`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}