$re = '/^\+?\d+(-\d+)*$/m';
$str = '12345
123-456
+12345
+12345-12345
123--123
123-------3242-324324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);