re = /^\+?\d+(-\d+)*$/m
str = '12345
123-456
+12345
+12345-12345
123--123
123-------3242-324324'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end