const regex = new RegExp('\\n', 'gmi')
const str = `Krátký popis s odřádkováním
a druhým řádkem.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);