$re = '/\n/mi';
$str = 'Krátký popis s odřádkováním
a druhým řádkem.';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;