use strict;
my $str = 'Krátký popis s odřádkováním
a druhým řádkem.';
my $regex = qr/\n/mip;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";