using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(([^<>]+?)>)([^<>]+?)(?=<(?!\1))";
string substitution = @"<$1$3</$2>";
string input = @"<a><ab><abc>111<abc2>222</ab></a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}