import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(([^<>]+?)>)([^<>]+?)(?=<(?!\\1))";
final String string = "<a><ab><abc>111<abc2>222</ab></a>";
final String subst = "<$1$3</$2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}