re = /<(([^<>]+?)>)([^<>]+?)(?=<(?!\1))/m
str = '<a><ab><abc>111<abc2>222</ab></a>'
subst = '<$1$3</$2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result