#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<script[^>]*id="(?!pagespeed\b)[^"]+".*<\/script>"
Local $sString = "<script sdfsvsv id="pagespeed".sdfsfgs</script>" & @CRLF & _
"<script ada id="adfa"adadf </script>" & @CRLF & _
"<scriptfdaad id="adfasdv"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")