$re = '/<script[^>]*id="(?!pagespeed\b)[^"]+".*<\/script>/m';
$str = '<script sdfsvsv id="pagespeed".sdfsfgs</script>
<script ada id="adfa"adadf </script>
<scriptfdaad id="adfasdv"</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);