using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script[^>]*id=""(?!pagespeed\b)[^""]+"".*<\/script>";
string input = @"<script sdfsvsv id=""pagespeed"".sdfsfgs</script>
<script ada id=""adfa""adadf </script>
<scriptfdaad id=""adfasdv""</script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}