#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)FLAGSHARE[\s\S]*?2015"
Local $sString = "FLAGSHARE" & @CRLF & _
" xxxxxx" & @CRLF & _
" xxxxx, 1 2015" & @CRLF & _
"" & @CRLF & _
" words...." & @CRLF & _
"" & @CRLF & _
"FLAGSHARE" & @CRLF & _
" xxxxxx" & @CRLF & _
" xxxxx, 2 2015" & @CRLF & _
"" & @CRLF & _
" words...." & @CRLF & _
"" & @CRLF & _
"FLAGSHARE" & @CRLF & _
" xxxxxx" & @CRLF & _
" xxxxx, 3 2015" & @CRLF & _
"" & @CRLF & _
" words...."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)