const regex = /FLAGSHARE[\s\S]*?2015/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('FLAGSHARE[\\s\\S]*?2015', 'gm')
const str = `FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);