// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)FLAGSHARE[\s\S]*?2015").unwrap();
let string = "FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}