using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(value[0-9]\=[0-9]+ ){2}value[0-9]\=([0-9]{4})";
string input = @"value1=2344 value2=2332 value3=3434";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}