re = /(value[0-9]\=[0-9]+ ){2}value[0-9]\=([0-9]{4})/
str = 'value1=2344 value2=2332 value3=3434'
# Print the match result
str.match(re) do |match|
puts match.to_s
end