$re = '/(value[0-9]\=[0-9]+ ){2}value[0-9]\=([0-9]{4})/';
$str = 'value1=2344 value2=2332 value3=3434';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);