# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\<a.*?www\.)([a-z]+\.[a-z]+)/&$1;/gm;t' <<< "<a href=\"https://www.domainurl.com/refer/google-adsense/\">fsdf</a>
<a title=\"Google Adsense\" href=\"https://www.domainurl.com/refer/google-adsense/\" target=\"_blank\" rel=\"nofollow noopener\">fgddf</a>
<a href=\"https://www.domainurl.com/page/pago\">domain </a>"