using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\<a.*?www\.)([a-z]+\.[a-z]+)";
string substitution = @"&$1;";
string input = @"<a href=""https://www.domainurl.com/refer/google-adsense/"">fsdf</a>
<a title=""Google Adsense"" href=""https://www.domainurl.com/refer/google-adsense/"" target=""_blank"" rel=""nofollow noopener"">fgddf</a>
<a href=""https://www.domainurl.com/page/pago"">domain </a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}