$re = '/(?<=\<a.*?www\.)([a-z]+\.[a-z]+)/m';
$str = '<a href="https://www.domainurl.com/refer/google-adsense/">fsdf</a>
<a title="Google Adsense" href="https://www.domainurl.com/refer/google-adsense/" target="_blank" rel="nofollow noopener">fgddf</a>
<a href="https://www.domainurl.com/page/pago">domain </a>';
$subst = "&$1;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;