package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)target.*?\".*\"`)
var str = `<a href="https://www.domainurl.com/refer/google-adsense/">fsdf</a>
<a title="Google Adsense" href="https://www.domainurl.com/refer/google-adsense/" target="_blank" rel="nofollow noopener">fgddf</a>
<a href="https://www.domainurl.com/page/pago">domain </a>`
var substitution = "&$1;"
fmt.Println(re.ReplaceAllString(str, substitution))
}