import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "target.*?\\\".*\\\"";
final String string = "<a href=\"https://www.domainurl.com/refer/google-adsense/\">fsdf</a>\n"
+ "<a title=\"Google Adsense\" href=\"https://www.domainurl.com/refer/google-adsense/\" target=\"_blank\" rel=\"nofollow noopener\">fgddf</a>\n"
+ "<a href=\"https://www.domainurl.com/page/pago\">domain </a>";
final String subst = "&$1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}