// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)target.*?\".*\""#).unwrap();
let string = "<a href=\"https://www.domainurl.com/refer/google-adsense/\">fsdf</a>
<a title=\"Google Adsense\" href=\"https://www.domainurl.com/refer/google-adsense/\" target=\"_blank\" rel=\"nofollow noopener\">fgddf</a>
<a href=\"https://www.domainurl.com/page/pago\">domain </a>";
let substitution = "&$1;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}