#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\<a.*?www\.)([a-z]+\.[a-z]+)(?:.*?(target.*?\".*\"))?"
Local $sString = "<a href="https://www.domainurl.com/refer/google-adsense/">fsdf</a>" & @CRLF & _
"<a title="Google Adsense" href="https://www.domainurl.com/refer/google-adsense/" target="_blank" rel="nofollow noopener">fgddf</a>" & @CRLF & _
"<a href="https://www.domainurl.com/page/pago">domain </a>"
Local $sSubst = "&$1;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)