use strict;
my $str = '<a href="https://www.domainurl.com/refer/google-adsense/">fsdf</a>
<a title="Google Adsense" href="https://www.domainurl.com/refer/google-adsense/" target="_blank" rel="nofollow noopener">fgddf</a>
<a href="https://www.domainurl.com/page/pago">domain </a>';
my $regex = qr/(?<=\<a.*?www\.)([a-z]+\.[a-z]+)(?:.*?(target.*?\".*\"))?/mp;
my $subst = '&$1;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";