const regex = /(?<=\<a.*?www\.)([a-z]+\.[a-z]+)(?:.*?(target.*?\".*\"))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<a.*?www\\.)([a-z]+\\.[a-z]+)(?:.*?(target.*?\\".*\\"))?', 'gm')
const str = `<a href="https://www.domainurl.com/refer/google-adsense/">fsdf</a>
<a title="Google Adsense" href="https://www.domainurl.com/refer/google-adsense/" target="_blank" rel="nofollow noopener">fgddf</a>
<a href="https://www.domainurl.com/page/pago">domain </a>`;
const subst = `&$1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);