const regex = /(?<!#)(focus)(?!#)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!#)(focus)(?!#)', 'gm')
const str = `focus;focus#focus#focus focus`;
const subst = `ale`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);