import Foundation
let pattern = ##"(?<!#)(focus)(?!#)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"focus;focus#focus#focus focus"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ale"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)